Cannot get automatic calibration to work

Cannot get automatic calibration to work

Postby Peter Williams » Sat Aug 20, 2022 5:17 am

Hi,

I have built a UVEX and a Calibrex and have begun “sea trials”.

When I installed Demetra I worked through the sample images, was able to successfully process them, and gained a reasonably clear understanding of what each step is doing.

I have tried many times to get the automatic calibration procedure to work with my own images with no success. I can do a manual calibration and process a spectrum satisfactorily.

I have tried
1) a helium discharge lamp which gives a lovely clean spectrum
2) a neon discharge lamp - much busier spectrum
3) sky calibration
4) Calibrex calibration lamp

When I try to process my object image it immediately fails and turns red
If I first try to process my calibration image when I press run nothing happens

I have opened the calibrate “tab” and have played with parameters in there to no avail.

I find Demetra to otherwise be very logical and easy to use -although I am somewhat baffled by the number of points in a fully processed spectrum - I assume there is some interpolation required to get the same number of points as the reference spectra to determine the response?

Related to that, I have access to a fully calibrated ocean optics spectrometer with which I took a helium spectrum. I measured the peak heights in that spectrum and the UVEX spectrum (I used Gaussian fits) and took the ratios to get a response curve for the UVEX/camera combination I am using. It came out quite nicely and was much as I expected it to be- the far red and blue ends fall of in sensitivy.

Questions

1) any suggestions to try to get the automatic calibration working?
2) is it possible to use the response curve I determined with the ocean optics spectrometer in Demetra?

Appreciate any suggestions you may have.

Sincerely,

Peter
Peter Williams
 
Posts: 7
Joined: Wed Aug 03, 2022 5:18 pm

Re: Cannot get automatic calibration to work

Postby Olivier GARDE » Sat Aug 20, 2022 7:32 am

Hi Peter,

For the wavelength calibration, Demetra is configured by default to be used with the following calibration module:
https://www.shelyak.com/produit/pf0037-module-detalonnage-alpy/

I'm not sure that in the calibrex, there is exactly the same lamp. According to the suppliers, the Ar/Ne bulbs do not provide exactly the same emission lines.
But if you know the values of the emission lines in your calibrex module, you can edit the list in Demetra.

For the response curve, you have to do it with your UVEX, camera and optical with a type A or B star close to your target.
LHIRES III #5, LISA, e-Shel, C14, RC400 Astrosib, AP1600
http://o.garde.free.fr/astro/Spectro1/Bienvenue.html
Olivier GARDE
 
Posts: 1199
Joined: Thu Sep 29, 2011 6:35 am
Location: Rhône Alpes FRANCE

Re: Cannot get automatic calibration to work

Postby Peter Williams » Sat Aug 20, 2022 9:43 pm

Dear Olivier,

Thank you so very much for this. I will see about editing things to make it work.

I am also very grateful for your guidance with respect to response.

Merci beaucoup!

Peter
Peter Williams
 
Posts: 7
Joined: Wed Aug 03, 2022 5:18 pm

Re: Cannot get automatic calibration to work

Postby Peter Williams » Sun Aug 21, 2022 8:39 pm

Dear Olivier,

I am so grateful to you - I got it to work!!!! Took quite a bit of trial and error but all is well now.

A question if I may be so indulgent. Your comment about using Type A or B stars to get the response is to ensure that atmospheric effects are also included - correct?

Thanks,

Peter
Peter Williams
 
Posts: 7
Joined: Wed Aug 03, 2022 5:18 pm

Re: Cannot get automatic calibration to work

Postby Olivier GARDE » Mon Aug 22, 2022 12:52 pm

Yes, the instrumental response in this case, take into account the high of the target in the sky for atmospheric transmission.

At the zenith, the airmass is 1, but at 30 degrees the airmass is 2....

that"s why you need to take a reference star close to each target.

You can use the spreadsheet made by François Teyssier to help you finding the right star :
http://www.astronomie-amateur.fr/Documents%20Spectro/ReferenceStarFinder_V3.xlsm
LHIRES III #5, LISA, e-Shel, C14, RC400 Astrosib, AP1600
http://o.garde.free.fr/astro/Spectro1/Bienvenue.html
Olivier GARDE
 
Posts: 1199
Joined: Thu Sep 29, 2011 6:35 am
Location: Rhône Alpes FRANCE

Re: Cannot get automatic calibration to work

Postby Peter Williams » Tue Aug 23, 2022 8:51 pm

What a fantastic resource- thank you so much for sharing and for
your patience with my simple questions

Sincerely

Peter
Peter Williams
 
Posts: 7
Joined: Wed Aug 03, 2022 5:18 pm

Re: Cannot get automatic calibration to work

Postby Robin Leadbeater » Tue Aug 23, 2022 10:55 pm

Hi Peter,

On flux calibration you might find this document of mine useful. It describes the factors which affect the response and the technique using a reference star measured at similar air mass.
http://www.threehillsobservatory.co.uk/ ... 201007.pdf
David Boyd's overview presentation running through the whole process of producing research quality spectra is good too
https://britastro.org/section_informati ... ur-spectra

Cheers
Robin
LHIRES III #29 ATIK314 ALPY 600/200 ATIK428 Star Analyser 100/200 C11 EQ6
http://www.threehillsobservatory.co.uk
Robin Leadbeater
 
Posts: 1862
Joined: Mon Sep 26, 2011 4:41 pm

Re: Cannot get automatic calibration to work

Postby Peter Williams » Mon Aug 29, 2022 5:08 pm

Hi Robin,

Thank you so much - two extremely useful resources.

Take care,

Peter
Peter Williams
 
Posts: 7
Joined: Wed Aug 03, 2022 5:18 pm


Return to Software Demetra

Who is online

Users browsing this forum: No registered users and 1 guest

x